ZBOX CI320

Wie es begann

ZBOX-CI320NANO 12
Vier Jahre lang hatte die ZBOX ID40 klaglos ihren Dienst getan, schließlich aber doch mit Debian "Wheezy". Dann entschied ein Gewitter, dass ich mal was Neues bräuchte, und grillte die Netzwerkchips. WLAN war mir entschieden zu langsam, weswegen sich etwas tun musste.

Die Hausratversicherung erstattete mir 200,00€ und so konnte ich auf die Pirsch gehen. Mit Zotac war ich hinreichend zufrieden, warum also nicht wieder einen MIni aus diesem Hause.

Schließlich entschied ich mich für eine CI320 mit 8GB Ram und einer Quad Celeron CPU und OHNE geräuschvollen Lüfter für 205,00€.

Installation

Es war im Laufe der letzten 4 Jahre so viel an Konfigurationsarbeit zusammengekommen, dass ich mich gegen eine Neuinstallation entschied und einfach die Platte umbauen wollte. Hardwareseitig war das überhaupt kein Problem, die kleine Box ist kinderleicht zu öffnen, das Ram Modul baut man leicht mit den üblichen Vorsichtsmaßnahmen ein und die Platte (max. 9,5 mm Höhe machte auch keinerlei Schwierigkeiten.

Die kleine Maschine bootete sofort, wollte aber nicht in den Grafikmodus. Kein Wunder, dachte ich, es ist ein Intel ValleyView Gen7 Chipsatz verbaut und kein Nvidia ION. Nach einigem Fummeln wurde die Intel-Grafik erkannt ... aber das Ergebnis war überaus langsam. Und Sound kam auch keiner aus dem HDMI Kabel, erkannt wurde nur analog Audio.

Meine erste Vermutung bewahrheitete sich: Der Chipsatz ist zu neu für Debian "Wheezy" Debian ist halt mal "kreuzkonservativ" und das wirkte sich diesmal eben negativ aus. Also doch eine Neuinstallation? Ubuntu? Oder gar OpenSuSE (grusel)?

Trotz etlicher Bedenken entschloss ich mich es mit Debian "Jessie", also der noch nicht als "stable" bezeichneten "testing" Version zu versuchen. Das Update geht ganz einfach, indem man:

  1. Die Datei /etc/apt/sources.list editieren und überall "wheezy" durch "testing" ersetzen.
  2. sudo apt-get update   
  3. sudo apt-get dist-upgrade

Das war's! Daß ich einige Probleme dabei hatte, und ich den dist-upgrade Prozess mehrmals anschubsen musste, führe ich darauf zurück, das just während des Upgrades mein LTE Kontingent aufgebraucht war und ich den gesamten Prozess mit 384 Kbit/s durchlaufen musste ... Letztlich hat das funktioniert, wenn es auch 5 Stunden gebraucht hat :-)

Und das Tollste: Die Grafik lief auf Anhieb superschnell und ein satter Sound kam aus meinem 5.1 System!!!

Die erste Hürde war genommen:

Probleme

Nun begannen aber doch die Probleme, ich möchte sie eher als Nacharbeiten bezeichnen.

Apache 2.4

Der bisher benutzte Apache 2.2 wird in Jessie durch 2.4 ersetzt. Dabei ergaben sich zwei für mich wesentliche Änderungen.

1. Das Vereichnis /etc/apache2/conf.d gibt es nicht mehr, statt dessen gibt es die beiden Verzeichnisse /etc/apache2/conf-enabled und etc/apache2/conf-available. Eigentlich ist das eine folgerichtige Weiterentwicklung schließlisch wird das bei den Modulen und den Sites schon lange so gemacht. Ich habe meine conf-Dateien einfach umkopiert und die entsprechenden Links gesetzt.

2. Die Direktiven "order deny, allow" und "allow from all" wurden ersetzt durch "require all denied" bzw "require all allowed". Ich musste etwas googlen, bis ich dfas herausgefunden hatte. Das war schon mehr Arbeit (weil an vielen Stellen benutzt) aber eben nur Arbeit.

ntp

Der USB to Serial Stick wurde nicht erkannt ... warum nur???

Weitere Probleme werden sicherlich noch folgen und dann hier dokumentiert

Nagios/Icinga

Natürlich wird mein Homeserverchen von Icinga überwacht. Leider hat man bei Debian, beschlossen, dass nrpe mit Kommandozeilen-Parametern zu "unsicher" ist und deswegen den nrpe entsprechend kompiliert. Mir hätte der entsprechende Schalte in der nrpe.conf Datei auch gereicht (Don't blame nrpe=1". Deswegen musste ich den nrpe-Dienst neu kompilieren. Geht ganz einfach:

cd /usr/src

wget http://downloads.sourceforge.net/project/nagios/nrpe-2.x/nrpe-2.15/nrpe-2.15.tar.gz

tar -xzvf wget nrpe-2.15.tar.gz

cd nrpe-2.15

./configure --with-ssl=/usr/bin/openssl --with-ssl-lib=/usr/lib/x86_64-linux-gnu/ --enable-command-args

make all

 

cp ./src/nrpe /usr/sbin/

Das letzte cp habe ich nur gemacht, weil ich nicht eine ganz neue Installation wollte. Ich muss ja nur nrpe austauschen. Allerdings muss ich nur darauf achten, dass ich diese Prozedur wiederhole, falls Debian das nrpe Paket updatet.

lm-sensors

Sensors ist ein sehr hübsches Tool, mit dem man die gesundheitszustände eines Servers auslesen kann. Dazu installiert man apt-get install lm-sensors und schon kann man mit "sensors" eine hübsche Information aus dem ganzen ziehen:

root@zbox:/etc/sensors.d# sensors
acpitz-virtual-0
Adapter: Virtual device
temp1:        +59.0°C  (crit = +90.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Core 0:       +64.0°C  (high = +105.0°C, crit = +105.0°C)
Core 1:       +64.0°C  (high = +105.0°C, crit = +105.0°C)
Core 2:       +63.0°C  (high = +105.0°C, crit = +105.0°C)
Core 3:       +64.0°C  (high = +105.0°C, crit = +105.0°C)

nct6776-isa-0a00
Adapter: ISA adapter
Vcore:        +0.81 V  (min =  +0.00 V, max =  +1.74 V)
in1:          +1.40 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
AVCC:         +3.33 V  (min =  +2.98 V, max =  +3.63 V)
+3.3V:        +3.31 V  (min =  +2.98 V, max =  +3.63 V)
in4:          +1.01 V  (min =  +0.00 V, max =  +0.00 V)  ALARM
in5:          +0.00 V  (min =  +0.00 V, max =  +0.00 V)
3VSB:         +3.30 V  (min =  +2.98 V, max =  +3.63 V)
Vbat:         +3.22 V  (min =  +2.70 V, max =  +3.63 V)
fan1:           0 RPM  (min =    0 RPM)  ALARM
fan2:           0 RPM  (min =    0 RPM)  ALARM
SYSTIN:       +38.0°C  (high =  +0.0°C, hyst =  +0.0°C)  ALARM  sensor = thermistor
CPUTIN:      +123.5°C  (high = +80.0°C, hyst = +75.0°C)  ALARM  sensor = thermistor
AUXTIN:      -128.0°C  (high = +80.0°C, hyst = +75.0°C)  sensor = thermistor
cpu0_vid:    +0.000 V
intrusion0:  ALARM
intrusion1:  ALARM

Mit Perl kann man sich ein kleines Check-Script schreiben, was man dann in Nagios/Icinga auswerten kann :-)

 

 

 

Kommentar schreiben


Sicherheitscode
Aktualisieren